The Heartbleed Hit List: The Passwords You Need to Change Right Now

Posted on April 21, 2014. Filed under: Passwords, Security | Tags: , , , |

The Heartbleed Hit List: The Passwords You Need to Change Right Now covers an updated list of which sites were vulnerable to the Heartbleed bug, and need a replacement password.

Right now.

Advertisements

Liked it here?
Why not try sites on the blogroll...

%d bloggers like this: